1 November 2017

Web app Release Notes 2017.10

Starting with this one, all future release notes will be posted in English to be able to serve our expanding customer base.
Please send all feature requests to idea@peepl.be.

General

  • "Community" was renamed to "Members portal" to better explain its purpose.
  • Comments: URLs are now recognized and made clickable.
  • Comments: improved the editing experience and enabled Admins to edit their own comments.
  • New Peepl accounts can choose to use the global peepl.io domain instead of the local peepl.be / peepl.nl domains.
  • New error message when a user's credentials are correct but he does not have the right permissions to log in.
  • Fixed a bug that prevented the text editor to apply styling in rare cases.
  • Many layout related bugfixes

CRM

  • Added new columns: Date joined / Last login / Last modified / Work / Education
  • Fixed a bug that caused the wrong group / function to be selected when loading the contact / organisation list.
  • Correctly translate the column names when exporting.
  • Changed "Municipality" to "Town/City"

Activities

  • At least 1 selected subscription type is required when subscribing for an open activity. Peepl no longer marks you as "not attending" automatically.
  • For free activities, we removed the unnecessary confirmation dialog in the attendance list admin page.
  • After creating a new activity, you are now always sent to the detail page.
  • Debit notes for activities are not generated for members whose subscription was free.
  • Added the reminder pattern form field when editing sale activities.
  • Activities are now cached for much better performance.
  • Updated the confirmation email's content to be more informative.

Communication

  • The search filter in mailings is now fixed. You can search for subject, author and tags.
  • Sending a mailing from a mailbox now redirects you to that mailbox.
  • Many improvements to email deliverability so that mailings don't end up in spam / promotion / social folders.

Photos

  • Removed the "Website" permission requirement for publishing photo albums to the website. The "Photos" permission now suffices.

Documents

  • Fixed a folder name conflict when trying to use a contact's exact full name as the folder name.

Financial

  • VAT number is now automatically copied to the wallet of an organisation upon creation.
  • Copying addresses from a contact / organisation to a linked wallet / invoice should now work properly.
  • Allowed new debit note to reuse the reference of deleted debit notes.

Module: Subscriptions

  • Sending an update now shows the exact counts of each category of recipients.

Settings

  • The License page now displays detailed information on your current storage limits.
  • Fixed a bug that would delete email addresses and phone numbers when using the "update" contacts with an Excel file.
  • The account's Contact Address could not be saved in certain edge cases.

iPhone app

  • Added the possibility to your organisation wallets to pay for an activity.